Dream Big with Focusrite - Win a dream recording weekend at Air Studios. Click here to enter

Saffire PRO Compatibility

The Saffire Pro is compatible with PCs running either Windows XP Service Pack 2, or Windows Vista. Both WDM and ASIO drivers are installed and so the Saffire is compatible with all applications that are compatible with these drivers. (i.e the majority of audio software).

Mac users will need to have an OS of 10.3.9 or above. The driver used is the Apple CoreAudio firewire driver. The driver is already part of OSX so the Saffire pro will work with all Mac audio applications.

Note that saffire cannot be used with Pro Tools on Mac or PC.
Saffire is not compatible with Gigastudio unless used in rewire mode with an ASIO host.