Logic 8 won't scan my Saffire Plugins on OS X 10.5 (Leopard)

The first time that you open up Logic 8 after installing the Saffire Plugins, the Plugins will be scanned by Logic's AU Validation. If this appears to freeze/crash, look in your dock and you should find a new AU Val icon there. Click on this and an error message will appear. If you click OK, you will be directed to this website:



You will then need to download the first of the 2 pieces of software, "InterLok Mac OS X extensions installer v5.5.1". After you have installed this, you should be prompted to authorise your Saffire Plugins as normal, and then Logic should continue to load.

If you continue to experience problems, please contact Customer Support.